System Performance with Overwolf

Note: For anyone using Teamspeak 3 & Overwolf Overlay with an NVIDIA GPU installed.

The other day I opened MSI Afterburner v4.3.0.9267 to check a couple of settings. I noticed the GPU & Memory usage was high even though the system was at idle. I discovered Overwolf was the culprit (GPU & Memory went back to idle once Overwolf was exited). I had the same issue with “Corsair Utility Engine” for the mouse (it too cranked up the GPU & Mem ). Worse, it “wouldn’t” allow the card to go beyond stock speeds (or reach boost speed, let alone O.C. settings). This lead to slightly slower performance because the GeForce GTX 1070 couldn’t reach it’s max stock speeds.

Here’s the fix for this (both Overwolf & Corsair Utility Engine - It might work with other troubled utility programs too).

(1). Open the NVIDIA control panel.
(2). Select “Manage 3d Settings” (left side on menu).
(3). Select “Program Settings” TAB.

(4). Select “ADD Program”.
(5). Browse where Overwolf is installed (Example: c:\programs files(x86)\Overwolf).
(6). Select the Overwolf.exe

(7). In the options (for that program only, not global) Turn off Anisotropic filtering and all anti-aliasing options; Set power management mode to optimal; Set Shader Cache to Off; Configure all Texture Filtering to Off or Performance; Lastly Set Triple buffering to Off

(8). Hit “Apply”.

(9). Select “ADD Program” again and do this for all the .exe files in the Overwolf install directory.
(10). Repeat steps 4-8 until you’ve created performance profiles for all of the .exe’s within the Overwolf install directory (minus the uninstaller).

Save any work & restart your system for changes to take effect.

Now the GPU should run at idle and be able to reach max stock & boost speeds with Overwolf & Corsair Utility Engine running. Plus… At idle, the GPU temps will go down, this should reduce fan rpm and noise.