Dynamic loadout issues and few other minors

Hey everyone,
I’ve tried to find an answer to this everywhere and asked several times but nobody knows. Every time I try to do a dynamic loadout in anything the engine turns on and goes to 100% until I exit the loadout menu. I’ve tried the whole leave group thing, I’ve checked key bindings, tried changing them no luck. I have yet to be able to change my loadout. It sucks lol. I’m using a thrustmaster t160000 hotas setup. I’m not sure it does it without the joystick unplugged. I should probably check that out.

Also anyone know how to get the throttle in heli to stop cutting out when you enter the chat or map?

chat throttle cutout issue is a BI bug everyone suffers from it in one way or another. makes flying and typing anything dangerous.
as for the first issue… no need to unplug anything, arma 3 allows you to disable controllers on the fly in game but I doubt its your controller. (unless the fact of not having a throttle bound is the cause…) also are you using the default or apex layout as your base for the keybinding setup? also look for anything yellow or red color which means you have duplicate controls set.

Arma does this to everyone. Dialog boxes etc didn’t do it in arma 2 but they changed their flight system for arma 3.

Essentially if you have a throttle then any dialog box or text box is going to kill your throttle, maybe to 20% or something stupid but I’ve never tested it. I just get some speed and type faster lol. So when you open dynamic loadout that is counted as a dialog box and it starts your engine.

Advanced flight model will not do this, I haven’t done advanced in a while but from what I remember none of this is an issue there. The engine will not start up (manual start up is required anyways) but also dialog boxes and the chat box do not interfere with throttle. The simple flight model is what does this. It has always done this, barely anyone talks about it but everyone has this issue and it looks like bohemia is never going to fix it.

So like he said you can go into controls before getting in (because pressing escape will also start the engines), and disable the throttle, do dynamic loadout, and then re-enable.

I have found a faster work around though: If you get into a helicopter and immediately start scrolling to the bottom and select dynamic loadout fast enough then it will not start the engines, the second you close that box it starts them. It seems to be that it might take a second for the throttle to kick in. (This works for pressing esc too but theres no need to go into controls since this works.)

Just wondering what preset ya set up for I know I dont have this issue when using the apex presets (never used default arma before had apex since I started playing)

I’m not sure. Probably apex.