Can't log on to LYTHIUM server

Per Admins advice, moving this issue here for public benefit. Using ONLY the two required LYTHIUM mods (Jbad and LYTHIUM) and logging on to server put me under water in a bay. Most objects were suspended above the map itself. Map looked tropical (Apex? - my normal Arma loading screen uses the Apex logo since adding that DLC). Trippy world, but obviously unplayable.

Admin suggests:

Delete MP cache files (where are those? - somewhere in the Arma directories I assume)

Unsubscribe and re-subscribe to the two mods - OK - that’s easy

You need to be cautious about deleting the MPCache files because they are in the hidden systems folder, I would prefer to talk you through it in TeamSpeak, but if you are confident in your abilities; First make sure Arma and the Arma Launcher are closed. Next, in Windows File Explorer paste “%localappdata%\Arma 3\MPMissionsCache” (without the quotes) in the address bar. In that folder locate and delete “Invade_&_Anne_NAK.lythium.pbo”

Next, start Arma 3 Launcher, unsubscribe and resubscribe to both the Lythium and Jbad mods. To be sure you are getting the correct versions of the mods, you can subscribe to them from our collection: Steam Workshop::NAK Lythium

When connection to the server via IP and the direct connect option, you need to make sure to enter the port as well, because the Lythium server uses a non standard port. If you do not enter the port, you will be connecting to the Malden server. The correct IP and port are:
IP Port: 2402.

If these options do not help, I really recommend talking to an admin on TeamSpeak.

After implementing Ace’s suggestions I am sorry to report that I still seem to be logging onto the same incorrect map (Tanoa?). Several launches and server re-connections result in the same thing. I also tried accepting both prompts about loading or keeping existing mods. Same result. I have been loading the mods in the launcher prior to log-ons. I did communicate with those on teamspeak on the server and one player said he had experienced the same thing. Basically, the LYTHIUM map does not seem to be loading. Don’t know where to turn next.

OK guys. Problem solved! Maybe you more experienced people already know about this, but I have only used a couple simple mods until now, basically, HUDs for heli’s, and have never had an issue by loading them in the launcher before logging on to the servers.

DO NOT pre-load the two required mods in the launcher! Log on to the server and let it bring up the loading Que for the mods, which you then agree to.